If you’re new to my Alfa Adventure, welcome! Otherwise, for the veterans, you know the story so far. Either way, you can read Part 1 or 2 by clicking on the numbers!

Long story short, I bought an Alfa Romeo 147 GTA in need of a little TLC and here’s part 3 of the installment.

It’s been almost a month now since my last Alfa Adventure update and there’s no other way to say it than we have gone backwards since then. What’s happened is that the ECU has been giving trouble and we can’t quite seem to find out what’s wrong with it so I’ve given it in to a specialist to rebuild, let’s see how that turns out. 

See if you can spot the difference between the photos below-

What the ECU is supposed to look like
Damaged Alfa 147 GTA ECU
Versus what mine looks like


Now as a result of the car sitting idle on the driveway for over a month, the battery has also died. Bummer. I tried to recharge said battery but that didn’t work either because the ECU wouldn’t let the car start.


Lastly, I would’ve also expected to have collected all my parts so far but the shipping company lost my package and it somehow ended up back with the sender after two weeks! Hopefully the package is actually on its way this time.

It has definitely been an uphill battle to get this car in shape but in some ways I have made life harder for myself by taking a working car and making it not working….
Hopefully I have good news for you in part 4 of my Alfa Adventure but for now, the 147 GTA makes for a nice piece of art.

The Alfa Romeo logo
Gosh, that badge itself is art
Share your love
Share on facebook
Facebook
Share on twitter
Twitter
Share on pinterest
Share on linkedin
Share on reddit
Share on mix
Share on pocket
Share on whatsapp
Share on telegram
Share on vk
Share on stumbleupon
Share on xing

Newsletter

Support our advertisers

Support our advertisers

Support our advertisers

Leave a Reply

Your email address will not be published. Required fields are marked *